VS Team Services Continuous Deployment

The Jenkins project announced an unresolved security vulnerability affecting the current version of this plugin (why?):

Deprecated: This plugin has been marked as deprecated. In general, this means that this plugin is either obsolete, no longer being developed, or may no longer work.

More information about the cause of this deprecation, and suggestions on how to proceed may be found in the documentation below.
22%
health score
Adoption
0%
The plugin is not marked as up for adoption.
100%
Cannot determine the last commit date.
-100%
Deprecation
0%
Plugin is marked as deprecated.
0%
Documentation
0%
The plugin relies on the global contributing guide.
0%
Repository Configuration
0%
Cannot confirm or not the JEP-229 configuration.
0%
No dependency version manager bot are used on the plugin repository.
0%
Cannot confirm or not the presence of Jenkinsfile.
0%
Security
0%
Plugin seem to have on-going security advisory.SECURITY-962
0%
Update Center Plugin Publication
100%
The plugin appears in the update-center.
100%